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1 Úvod 
 

Tento dokument obsahuje používateľskú príručku k systému FleXtat, vytvorenom  

v rámci tímového projektu na FIIT STU.  

Systém  FleXtat (FLEXible sTATistics system)  je určený pre štatistické vyhodnocovanie 

elektronickej prihlášky. Umožňuje jednoduchým a pohodlným spôsobom vygenerovať 

štatistiku založenú na informáciách o elektronických prihláškach. Vygenerovaná štatistika 

prezentuje údaje vo forme tabuliek a grafov. Tieto údaje je možné v ucelenej forme ďalej 

exportovať do rôznych formátov, a tým zabezpečiť publikovanie týchto výsledkov rôznymi 

spôsobmi. 
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2 Prehľad o systéme 
V rámci systému FleXtat sú definované nasledujúce tri role používateľov. Každá 

z týchto rolí umožňuje riadenie systému na inej úrovni a iným spôsobom. 

 

• referent – bežný používateľ, ktorý chce získavať štatistické informácie, napr. 

administratívna pracovníčka na študijnom oddelení, dekan, profesor 

• editor – osoba, ktorej bude umožnené vytvárať zostavy,  editovať ich obsah 

• administrátor – špeciálny používateľ s možnosťami správy databázy 

 

Hlavnou časťou systému je aplikácia FleXtat Browser, ktorá poskuje rozhranie pre 

všetkých používateľov. Aplikácia vykonáva generovanie zostáv, ich tlač a export do vybraných 

formátov, spolu s funkciami umožňujúcimi editorovi vytvorenie a správu zostáv.  Okrem 

samotnej aplikácie FleXtat Browser používa editor už existujúcu open-source aplikáciu 

iReport ktorá slúži na vizuálny návrh a editáciu zostáv. Pre pohodlné vytváranie zostáv bol 

pre aplikáciu vytvorený modul flextat report wizard.  

 

Referent

Editor

FleXtat Browser

Databáza FleXtat

Administrátor

Databáza E-App
FleXpump

Aplikácia iReport

 

Obr. 1: Konceptuálna schéma architektúry systému 

Existujúce zostavy spolu s dátami pre ne určenými, sú uložené v databáze FleXtat. 

Databáza je podľa požiadaviek aktualizovaná administrátorom pomocou SQL skriptu 

FleXpump ktorý vykonáva aktualizáciu z databázy elektronickej prihlášky E-App.  

Administrátor má ako jediný neobmedzený prístup k databáze FleXtat a preto je schopný 

vykonávať jej zálohu a obnovu. 
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3 Inštalácia 

3.1 FleXtat Browser 

K inštalácií aplikácie FleXtat Browser je potrebné vykonať nasledujúce kroky: 

1. V prípade ak nie je nainštalovaný Java 2 Standard Edition 1.4.2  Runtime Environment  

je potrebné ho nainštalovať z inštalačného média prípadne zo stránky: 

http://java.sun.com/j2se/1.4.2/download.html kliknutím na „Download J2SE JRE“. 

2. Skopírovať adresár s aplikáciou FleXtat Browser z inštalačného média do inštalačného 

adresára. 

3. Skontrolovať a v prípade potreby zmeniť nastavenia konektivity v súbore config.xml 

v inštalačnom adresári. 

 

 

3.2 iReport + fleXtat report wizard plugin 

K inštalácií aplikácie iReport je potrebné vykonať nasledujúce kroky: 

1. V prípade ak nie je nainštalovaný Java 2 Standard Edition 1.4.2  Runtime Environment  

je potrebné ho nainštalovať z inštalačného média prípadne o stránky: 

http://java.sun.com/j2se/1.4.2/download.html kliknutím na „Download J2SE JRE“. 

2. Skopírovať adresár s aplikáciou iReport z inštalačného média do inštalačného adresára 

aplikácie FleXtat Browser. 

 

V prípade, že si prajete používať plugin vo forme sprievodcu, ktorý Vám uľahčí úvodné 

vytváranie zostáv v spojení s databázou fleXtat, postupujte nasledovne: 

1. Skopírujte adresár lib a plugins do adresára nainštalovaného iReportu 

2. Spustite iReport a skonfigurujte plugin v menu Tools -> Configure plugins 

3. Zvoľte položku fleXtat report plugin v zozname dostupných pluginov a stlačte tlačidlo 

Configure (Obr. 2). 

4. Konfiguračný dialóg upozorní na to, že musí existovať spojenie na fleXtat databázu 

s názvom flexdb. Ak ešte neexistuje, v nasledujúcom dialógovom okne ho treba 

vytvoriť (Obr. 3). Na to slúži tlačidlo New. Treba vytvoriť spojenie na základe 

nasledovného dialógového okna (Obr. 4). 

5. Ako posledný krok je potrebné v menu Build -> Set active connection nastaviť aktívne 

spojenie práve na databázu fleXtat, resp. na spojenie flexdb. 

 

http://java.sun.com/j2se/1.4.2/download.html
http://java.sun.com/j2se/1.4.2/download.html
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Obr. 2: Konfigurácia pluginu 

 

 

 

Obr. 3: Spojenia / dátové zdroje 
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Obr. 4: Vlastnosti spojenia 

 

3.3 FleXpump 

K inštalácií FleXpump je potrebné vykonať nasledujúce kroky: 

1. V prípade ak nie je nainštalovaný Java 2 Standard Edition 1.4.2  Runtime Environment  

je potrebné ho nainštalovať z inštalačného média prípadne o stránky: 

http://java.sun.com/j2se/1.4.2/download.html kliknutím na „Download J2SE JRE“. 

2. Skopírovať adresár s aplikáciou FleXpump z inštalačného média do inštalačného 

adresára aplikácie FleXtat Browser. 

 

 

3.4 Databáza FleXtat 

K inštalácií databázy FleXtat je potrebné vykonať nasledujúce kroky: 

1. V prípade ak nie je nainštalovaný Postgre SQL Server je potrebné ho nainštalovať. 

Inštalačne súbory je možné získať  zo stránky stiahnutím zo stránky: 

http://www.postgresql.org/download/   

2. Vytvoriť databázu na serveri 

3. Upraviť  nastavenia v skripte na inštalačnom médiu týkajúce sa databázy E-APP 

a spustenie tohto skriptu 

4. Spustenie aplikácie FleXpump 

5. Upravenie súboru config.xml podľa aktuálnych nastavení a jeho distribúcia 

http://java.sun.com/j2se/1.4.2/download.html
http://www.postgresql.org/download/
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4 FleXtat Browser 
Aplikácia FleXtat Browser sa spustí súborom flextat.bat v inštalačnom adresári 

aplikácie. Po spustení sa objaví prihlasovacia obrazovka, kde je potrebné zadať svoje 

prihlasovacie meno a heslo. 

 

 

Obr. 5: Prihlasovací dialog FleXtat Browser  

 

 

Obr. 6: Hlavné okno aplikácie FleXtat Browser  
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Po správnom prihlásení sa objaví hlavné okno celej aplikácie FleXtat Browser, ktoré 

pozostáva okrem priestoru na zobrazenie vygenerovanej zostavy ešte z nasledujúcich častí: 

• Hlavné menu – poskytuje možnosti závislé na type používateľa hlavné položky 

• Panel nástrojov – všeobecné príkazy používané v súvislosti so zostavou 

• Strom zostáv – umožňuje hierarchické zobrazenie všetkých reportov uložených 

v databáze 

• Panel vlastností – priestor, kde sa zobrazia vlastnosti elementu zostavy, na 

ktorý bolo kliknuté 

4.1 Prezeranie zostáv 

Prezeranie konkrétnej zostavy sa realizuje rozbalením uzla v strome zostáv, pod 

ktorým sa konkrétna zostava nachádza a kliknutím na ňu. Na ovládanie prehliadania zostáv 

slúži panel nástrojov. Základné operácie, ktoré je možné realizovať cez panel nástrojov, sú 

nasledujúce: 

 

  - obnovenie zostavy, v prípade zmeny vlastností niektorých elementov zostavy 

(napr. farby grafu), je potrebné znovu vygenerovať zobrazenie zostavy, aby sa 

dané zmeny prejavili 

 

  - export zostavy do zvoleného formátu – v súčasnosti sú podporované formáty pdf 

a xml 

 

  - tlač zostavy 

 

  - množina tlačidiel určených na posun medzi jednotlivými 

stranami zostavy, umožňuje taktiež skočiť na prvú alebo poslednú, prípadne 

konkrétnu stranu zostavy 

 

  - množina tlačidiel na zobrazenie zostavy s rôznym 

náhľadom. Používateľ môže dynamicky zväčšovať a zmenšovať tento náhľad. 

 

4.2 Nastavovanie vlastností zostáv 

Aplikácia FleXtat umožňuje nastaviť niektoré základné vlastnosti textu, obrázku alebo 

grafu. Na nasledujúcom obrázku je ukážka zobrazenia vlastností pre text a graf. 
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Obr. 7: Ukážka nastavovania vlastností 

 

Zobrazovanie vlastností a ich zmena je intuitívna a je známa z viacerých editorov. Po 

zmene konkrétnej vlastnosti je potrebné pre jej realizáciu stlačiť tlačidlo „obnovenie zostavy“ 

popísané vyššie alebo klávesovú skratku F5. 

4.3 Práca so zostavami 

Všetky zostavy sú zobrazené v strome, na ľavej strane obrazovky. Tieto zostavy je 

možné podľa potreby umiestňovať do hierarchickej štruktúry kvôli jednoduchšej orientácii 

v zostavách. Preto aplikácia umožňuje vytvárať kategórie, do ktorých je možné vkladať 

konkrétne zostavy. Celkový pohľad na strom zostáv je zobrazený na obrázku č.5. 
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Obr. 8: Strom zostáv 

 

Hlavná kategória, ktorá je vytvorená automaticky pri inštalácii je kategória „Štatistiky“. 

K tejto kategórii je možné vytvoriť nové podkategórie. Tu je potrebné stlačením lavého 

tlačítka myši zvoliť vybratú kategóriu a pravým tlačítkom vyvolať kontextové menu, zobrazené 

na nasledovnom obrázku. 

 

 

Obr. 9: Kontextové menu na prácu s kategóriami 

 

Na pridanie novej podkategórie je potrebné zvoliť položku „Nová kategória“. Po tejto 

voľbe sa zobrazí nasledovná obrazovka. 

 

 

Obr. 10: Vytváranie novej kategórie 

 

 Tu je potrebné vyplniť názov kategórie, ktorá nemusí byť v celom systéme unikátna. 

Takto vytvorenú kategóriu je možné upraviť, vyvolaním položky „upraviť kategóriu“ 
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z kontextového menu. Tu aplikácia poskytne dialógové okno na zmenu menovky kategórie, 

zobrazené na obrázku č.11. 

 

Obr. 11: Možnosti dátového zdroja 

 

Túto kategóriu je možné odstrániť. Jedinou podmienkou na odstránenie je tá, aby bola 

kategória prázdna, t.j. aby neobsahovala žiadne zostavy. Odstrániť kategóriu je možné 

zvolením položky „Odstrániť kategóriu“ z kontextového menu, alebo stlačením tlačidla 

„Delete“. Pri tejto akcii sa zobrazí nasledovné dialógové okno. Účelom tohto dialógového okna 

je zábrániť nechcenému odstrániu kategórie, preto ak používateľ chce skutočne odstrániť 

kategóriu, musí stlačiť tlačidlo „OK“. 

 

Obr. 12: Odstránenie kategórie 

 

Pridávanie novej zostavy je možné vyvolať z kontextového menu, alebo stlačením  

klávesovej skratky „CTRL+N”. Ďalším krokom je zobrazenie dialógového okna zobrazeného na 

obrázku č.13.  

 

Obr. 13: Pridávanie novej zostavy 

 

Tu je potrebné zadať menovku zostavy, ktorá musí byť v celom systéme jedinečná. 

Ďalšou potrebnou položkou sú súbor zostavy a typ dátového zdroja. Súbor zostavy 

predstavuje súbor „jrxml“, ktorý reprezentuje samotnú zostavu. Typ dátového zdroja je  

• Scriptlet – určený na preddefinované zostavy 
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• Databáza – určený na používateľom definované zostavy, ktoré pracujú nad 

dátami z databázy 

• Žiadny – nie je potrebný žiadny dátový zdroj 

 

Tie možnosti sú uvedené na nasledovnom obrázku. 

 

Obr. 14: Možnosti dátového zdroja 

 

Taktiež je možné upravovať nastavenia zostavy a odstraňovať zostavy, táto možnosť je 

však analogická ku odstraňovaniu a upravovaniu kategórií, uvedenej vyššie. 

 

4.4 Administrácia používateľov systému 

Administrátorovi je umožnené pridávať, odoberať resp. nastavovať vlastnosti 

konkrétnym používateľom systému. Administráciu používateľov je možné iniciovať pomocou 

hlavného menu kliknutím na Používatelia -> Správa používateľov. Výberom konkrétneho 

používateľa v ľavom zozname a kliknutím na  sa objaví dialóg na editovanie konkrétneho 

používateľa. Používateľ má priradenú práve jednu rolu: referent, editor alebo administrátor. 
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Obr. 15: Správa používateľov   
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5 Práca s databázou 

5.1 Vytvorenie databázy 

Databáza sa vytvára pomocou priloženého skriptu flexdb.sql. Tento skript vytvorí 

všetky potrebné tabuľky, obmedzenia a triggre. 

5.2 FleXPump 

Aplikácia FleXPump slúži na prenos údajov z databázy aplikácie elektronickej prihlášky 

do databázy systému FleXtat. Pred použitím pumpy je potrebné, aby bola vytvorená databáza 

fleXDB a v prípade, že bude pumpa spúšťaná z iného počítača, ako je počítač, na ktorom je 

nasadená databáza, je potrebné, aby bolo povolené pripájanie sa na databázu z tohto stroja.  

Konfiguračné informácie pre pumpu sa nachádzajú v súbore FXPumpConfig.xml. 

Konfiguračné informácie je však možné uložiť do ľubovoľného XML súboru, ktorý obsahuje 

elementy : url1, user1, password1, url2, user2 a password2.  

Pre spustenie pumpy je potrebné mať nainštalovaný Java Runtime Environment 

a v prostredí musí byť nastavená cesta k spustiteľnému súboru java. Pumpa sa spúšťa 

príkazom java –jar FXPump.jar [/?|--help|] || [cesta k XML konfiguračnému súboru] && 

[cesta k XML súboru s jazykovou verziou]. 

5.3 Zálohovanie databázy 

Ak je potrebné urobiť backup databázy, musíte kontaktovat administrátora systému. 

Administrátor urobí záložný súbor z existujúcej aktuálnej databázy fleXtat. Je potrebné, aby 

sa takýto backup robil lokálne na databázovom serveri. Najúplnejším backup nastrojom je 

priama podpora od výrobcov databázového servera. Záloha sa spúšta príkazom 

 

    pg_dump -u meno_databazy > meno_backup_suboru 

 

Tento backup však nezálohuje používateľov a používateľské skupiny. Nakoľko aplikácia 

fleXtat využíva na overovanie mena a hesla používateľa interné procesy SQL servera, je 

potrebné zabezpečiť aj odzálohovanie používateľov a skupín v rámci servera. Tento krok je 

však potrebné spraviť samostatne. 

5.4 Obnova databázy 

Pri obnove databázy systému fleXtat je potrebné dodržať rovnaký postup, ako pri jej 

zálohe. Administrátor systému z existujúceho zálohového súboru dokáže plne obnoviť 

databázu. Avšak, ak sa pred obnovou nenachádza na serveri databáza, treba ju vytvoriť, 
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pretože obnova databázy obnoví iba štruktúru a dáta. Na vytvorenie databázy je možné použiť 

aj jeden z interných šablón postreSQL. Databáza sa tak dá vytvoriť príkazom 

 

 

    createdb -T template0 meno_databazy 

 

Po vytvorení databázy je vhodné obnoviť používateľov a skupiny používateľov v SQL 

serveri. Tento krok je potrebné zabezpečiť zo strany administrátora SQL servera. 

Nakoniec po ich obnove je možné plne obnoviť dáta v databáze lokálne na serveri 

fleXtat príkazom 

 

    psql meno_databazy < meno_backup_suboru 
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6 fleXtat report wizard 
Plugin fleXtat report wizard v aplikácii iReport slúži na vytváranie zostáv nad databázou 

fleXtat z preddefinovaných šablón. V niekoľkých krokoch prevedie používateľa procesom, 

počnúc voľbou faktov, cez voľbu šablóny, integrovanie tabuľky alebo pridanie grafu do 

výslednej zostavy. Sprievodca intuitívnym spôsobom vedie používateľa a v závere mu 

umožňuje upraviť vygenerovanú zostavu v aplikácii iReport. 

 

6.1 Krok 1 a 2 – privítanie a výber faktov 

V prvom kroku (Obr. 16) je používateľ oboznámený s účelom sprievodcu a zároveň je 

vyzvaný k dôkladnému premysleniu si kľúčových častí zostavy, ktorú sa chystá navrhnúť. 

 

Obr. 16: Privítanie 

 

Po kliknutí na tlačidlo Next sprievodca pokročí na krok č. 2 (Obr. 17). Používateľovi 

ponúkne množinu dostupných faktov v zozname, umiestnenom naľavo. Následne má 

používateľ možnosť zvoliť si želané fakty kliknutím na fakt a potom na tlačidlo . Zvolený 

fakt sa premiestni na pravú stranu do tabuľky zvolených faktov. Tlačidlom  sa presunú 

všetky dostupné fakty medzi zvolené fakty. Tlačidlá  a  majú opačný význam – presúvajú 

fakty zo zoznamu zvolených faktov naspäť medzi dostupné fakty. Výber faktov je kľúčový pre 

výslednú zostavu. Nad faktami sa dajú vykonávať aj rôzne funkcie – početnosť, suma, priemer 

(Obr. 18). Z charakteru databázy momentálne vyplýva, že napr. v prípade zisťovania 

početnosti prihlášok podľa národností je potrebné nastaviť agregačnú funkciu na fakt 

application a na fakt nationality nenastaviť funkciu. 
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Obr. 17: Voľba faktov 

 

 

 

Obr. 18: Nastavenie funkcie 

 

6.2 Krok 3 – zoskupovanie faktov 

V tomto kroku má používateľ možnosť zadefinovať zoskupovanie faktov. Sprievodca mu 

umožňuje zadefinovať štyri skupiny. Výsledná zostava bude zoskupená postupne od prvej 

zvolenej skupiny až po štvrtú (v prípade, že sú zvolené štyri skupiny). V nadväznosti na 

príklad z druhého kroku používateľ môže zvoliť zoskupovanie podľa národnosti (Obr. 19), čiže 

vo výsledku bude početnosť prihlášok zoskupená podľa tohto faktu. 
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Obr. 19: Zoskupovanie faktov 

6.3 Krok 4 – Voľba rozmiestenia 

V štvrtok kroku má používateľ možnosť zvoliť si niektorú z preddefinovaných šablón 

(Obr 20). Šablóny sú rozdelené na dve kategórie – stĺpcové a tabuľkové. Stĺpcové 

reprezentujú fakty v stĺpci pri ľavom okraji tabuľky a tabuľkové reprezentujú fakty v prvom 

riadku tabuľky vo forme hlavičky. Druh šablóny je možné zvoliť v rozbaľovanom poli. Zvolený 

orientačný vzhľad zostavy môže používateľ vidieť vedľa zoznamu dostupných šablón. Ak si 

želá zahrnúť vo výslednej zostave aj tabuľku, stačí nechať zaškrtnutú možnosť Insert table in 

the report. 

 

 

Obr. 20: Voľba rozmiestenia 
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6.4 Krok 5 – Vloženie grafu 

Piaty krok ponúka používateľovi možnosť vložiť graf do výslednej zostavy ( Obr. 21). 

Ak si používateľ neželá graf, zruší zaškrtnutie v poli Insert chart to the report. V ľavom 

zozname sa nachádzajú všetky dostupné grafy. Každý graf vyžaduje dva až tri parametre. 

Kruhové grafy požadujú dva – nápis a sériu. Nápis načítava hodnoty z definovaného faktu 

a vo výslednom grafe sa zobrazí ako vysvetľujúci nápis danej hodnoty. Séria definuje zdroj 

hodnôt grafu. Vyžadované parametre sa definujú v tabuľke napravo. Pre každý parameter 

existuje rozbaľovacie pole so zoznamom dostupných faktov, z ktorých si môže používateľ 

zvoliť želaný. V prípade, že graf sa má vložiť do zostavy, je potrebné zvoliť niektorý z grafov a 

vyplniť všetky parametre. V nadväznosti na príklad môže používateľ zvoliť kruhový 3D graf, 

v ktorom nadefinuje ako nápisy v grafe fakt národnosť a ako zdroj údajov početnosť prihlášok. 

 

 

Obr. 21: Vloženie grafu 

6.5 Krok 6 – záver 

V poslednom kroku sprievodcu má používateľ možnosť sa stále ešte vrátiť a pozmeniť 

niektoré predchádzajúce kroky. Ak súhlasí s navrhovaným rozložením, vyplnenými poľami 

a želá si vygenerovať zostavu, stačí stlačiť tlačidlo Finish (Obr. 22). 
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Obr. 22: Záver 

 

Výsledná vygenerovaná zostava sa objaví v prostredí aplikácie iReport (Obr. 23). 

 

Obr. 23: Vygenerovaná zostava 
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Používateľ musí nastaviť jedinečné meno zostavy v prípade, že ju chce pridať do 

databázy. Meno nesmie obsahovať medzery. Meno zostavy sa nastavuje cez menu View -> 

Report properties. Používateľovi sa zobrazí dialóg s vlastnosťami zostavy (Obr. 24). Používateľ 

(v roli editora) si môže prezrieť, ktoré mená zostavy existujú v aplikácii FleXat Browser 

v zozname vlastností každej zostavy. V prípade, že v aplikácii FleXtat Browser bude náhodou 

meno kolidovať, používateľ bude upozornený, že také meno existuje a aplikácia mu neumožní 

vložiť danú zostavu. Bude musieť zmeniť meno zostavy opäť v aplikácii iReport. 

 

 

Obr. 24: Vlastnosti zostavy 

 

Ak si používateľ praje prezrieť výslednú zostavu aj s naplnenými dátami z databázy, 

môže spustiť zostavu cez menu Build -> Execute report (using active conn.). 
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7 iReport – manuálna tvorba nových zostáv 
V tejto kapitole sa nachádza popis jednotlivých krokov potrebných pre tvorbu vlastnej 

zostavy v iReporte, ktorá je použiteľná v systéme FleXtat. V niektorých prípadoch je manuálne 

vytvorenie zostavy výhodnejšie ako použitie sprievodcu na vytváranie zostáv v iReporte. 

Výhody manuálnej tvorby sa prejavia najmä pri implementácii špeciálnych zostáv 

previazaných na dátový zdroj implementovaný v scriptlete – špeciálnom kóde určenom na 

spracovanie výsledkov prezentovaných v zostave. Tento manuál sa zaoberá iba niekoľkými 

vybranými vlastnosťami aplikácie iReport, ktoré sú nevyhnutné pre tvorbu zostáv. V princípe 

popisuje niektoré dôležité činnosti, ktoré je potrebné vykonať, aby mohla byť zostava 

použiteľná v systéme FleXtat. Tieto činnosti, ktoré sú pri použití sprievodcu vykonávané 

automaticky, je potrebné pri manuálnej tvorbe zostavy realizovať ručne. 

V princípe existujú dve možnosti, ako sú generovanej zostave dodané dáta, ktoré 

prezentuje. V prvom prípade sú dáta  získavané priamo napojením na databázu. V zostave je 

definovaný dotaz na databázu, ktorého výstup je následne v zostave spracovaný 

a prezentovaný. Druhý spôsob je nepriame prepojenie pomocou špeciálneho kódu – scriptletu. 

Pri tejto realizácii sa pred samotným generovaním zostavy spúšťa kód scriptletu, následne sú 

naplnené vybrané dátové elementy zostavy, použité na uloženie dát prezentovaných 

zostavou. 

 

Dátové elementy, ktoré zabezpečujú prenos informácii medzi zostavou a scriptletom sú 

nasledujúcich typov: 

a) parametre (parameters) – sú nastavované pri definícii zostavy a ich hodnota sa 

v priebehu celého procesu generovania zostavy nesmie meniť. Parametre zostavy sú ideálny 

spôsob, ako predať scriptletu dôležité inicializačné informácie, na základe ktorých sú potom 

iné dátové elementy generované. Parametre sa nastavujú kliknutím na View -> Report 

Parameters. Parameter, ako aj ostatné dátové typy musia mať definovaný korešpondujúci typ 

a hodnotu. Hodnota, napr. pre reťazec musí byť zadaná nasledujúcim spôsobom: new 

String(“Hello World”). 

b) polia (fields) – sú základom pre zobrazovanie hodnôt v tabuľkách. Pole hodnôt 

reprezentuje obsah konkrétneho stĺpca v tabuľke zostavy. Polia sú nastavované scriptletom 

alebo pri absencii scriptletu sú previazané s konkrétnym stĺpcom dotazu na databázu. Polia sa 

definujú kliknutím na View -> Report Fields. 

c) série (series) – sú špeciálne zoznamy hodnôt určené ako zdroje dát pre grafy. 

Uvedený príklad troch sérii reprezentuje dáta potrebné pre zobrazenie uvedeného stĺpcového 

grafu. Série sa definujú kliknutím na View -> Report Series. 
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Obr. 25: Príklad generovaného grafu 

 

SERIE_Kategorie SERIE_Pohlavia SERIE_Hodnoty 
do 18 rokov Muži                4 

18 – 20 rokov Muži             541 
20 – 22 rokov Muži             661 
nad 22 rokov Muži              38 
do 18 rokov Ženy               0 

18 – 20 rokov Ženy              28 
20 – 22 rokov Ženy              31 
nad 22 rokov Ženy                1 

Tab.  1: Série hodnôt pre graf 

 

d) premenné (variables) – majú veľký význam pri predávaní jednej hodnoty zo 

scriptletu do zostavy napr. v prípade keď scriplet počíta špeciálnu štatistickú funkciu. 

Základné štatistické funkcie je možné definovať nad konkrétnym poľom priamo v zostave 

kliknutím na View -> Report Variables. 

 

Príklad postupu pri vytváraní novej zostavy: 

1. Vytvoriť novú zostavu kliknutím na File -> New Document. Je potrebné, aby názov 

zostavy bol unikátny v rámci celého štatistického systému. 

2. Uložiť novú zostavu kliknutím na File -> Save 

3. Vytvoriť nadpisy kliknutím na  a umiestnením textu do sekcie: „title“, alebo do 

sekcie „column header“ pre nadpisy stĺpcov, prípadne do sekcie „summary“ pre 

sumárne informácie. 

4. Odstrániť nepotrebné sekcie zostavy ich minimalizovaním na nulovú veľkosť. Sekcie, 

ktoré sú použité v preddefinovaných zostavách, sú znázornené na nasledujúcom 

obrázku. 
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Obr. 26: Typický príklad zostavy a použitých sekcii 

 

 

5. Definovať zobrazené polia v sekcii „detail“, ktoré budú zobrazované v grafe kliknutím 

na . Polia musia byť následne zadefinované cez View -> Report Fields. 

6. Definovať zobrazené hodnoty premenných tým istým spôsobom ako polia, s tým 

rozdielom, že prefix $F nahradíme prefixom $V. Všetky premenné musia byť následne 

zadefinované cez View -> Report Variables. 

7. Vytvoriť ohraničenie tabuľky, stĺpcov a riadkov kliknutím na vytváranie čiar . Čiary 

podľa požiadaviek, kde sa majú zobraziť, je potrebné umiestniť do zodpovedajúcej 

sekcie. 

8. Definovať všetky parametre pomocou View -> Report Parameters. 

9. Definovať série použité v grafoch pomocou View -> Report Series. 

10. Vytvoriť grafy kliknutím na  a umiestnením grafu v sekcii „summary“. Pre graf je 

potrebné definovať typ grafu, série a parametre. Tieto parametre sa nastavujú 

spôsobom znázorneným na nasledujúcom obrázku. 
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Obr. 27: Postup nastavovania vlastností grafov 

11. Definovať scriptlet zostavy pomocou View -> Report Properties -> Scriptlet. Položku 

„Scriptlet class“ treba nastaviť na hodnotu „Use this scriptlet class ...“ a následne zadať 

plnú cestu k triede scriptletu 

     (napr. org.fellas.flextat.reportrepository.scriptlets.FXReport1Scriplet) 


